Ballast advice needed RCA M50WH92S

Moderator: Angel

Post Reply
drdreww
Newbie
Newbie
Posts: 2
Joined: Thu Oct 28, 2010 7:39 pm

Ballast advice needed RCA M50WH92S

Post by drdreww » Thu Oct 28, 2010 8:34 pm

So I just got this TV off of craigslist and it worked fine for a week. then it started having the RCA 5blinks of death. so i vacuumed and canned air it all out hoping it might get better with better airflow. it started working again for a week then started again. the tv comes on just fine, then after seemingly random increments of time the bulb would turn off but the sound would stay on, 5 blinks of the power light then come on again. have been doing alot of research and from other peoples problems i concurred that it is probably the ballast. i could hear it audibly snapping/clicking 2-15 times before the bulb would turn on. so i pulled the whole back off and found some suspicious stuff on the ballast board.

Image

Uploaded with ImageShack.usImage

Uploaded with ImageShack.us



has anyone dealt with this before?
is there still a possibility that it is the bulb?
am i looking at having to get a whole new ballast?
or could i maybe just replace that transformer since it still works sometimes.

thanks for your help guys!

User avatar
grayfox
Jedi Master
Jedi Master
Posts: 1049
Joined: Sat Jun 13, 2009 9:40 pm
Location: Sunny San Diego!
Contact:

Re: Ballast advice needed RCA M50WH92S

Post by grayfox » Sun Feb 06, 2011 10:51 pm

hello,
if you can get the transformers, there is still a chance this might not fix the problem, I would settle for exchanging the ballast altogether..
ImageUnit Foxhound

Post Reply

Return to “RCA Discussion”