HD61LPW52 no lamp or color wheel power

Moderator: Angel

Post Reply
whitey
Newbie
Newbie
Posts: 2
Joined: Sun Aug 30, 2009 3:10 am

HD61LPW52 no lamp or color wheel power

Post by whitey » Sun Aug 30, 2009 3:13 am

i have a RCA DLP HD61LPW52 tv. The lamp and color wheel does not turn
on. i have checked the power supply and have 310 volts to the ballast
but does not go through to the lamp. The power light is on, not flashing
and will not shut off until power cord is pull from the wall. The lamp
appears to be in good condition.
Do you think i should order the ballast first? :mrgreen:

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: HD61LPW52 no lamp or color wheel power

Post by mitchkramez » Mon Aug 31, 2009 1:41 pm

it's probably worth looking to see if you have bad caps. 310v seems pretty low, it should be 320-380v... and the fact that nothing is spinning or starting up, seems like a power supply issue... the color wheel should spin up first if everything is working ok.

whitey
Newbie
Newbie
Posts: 2
Joined: Sun Aug 30, 2009 3:10 am

Re: HD61LPW52 no lamp or color wheel power

Post by whitey » Mon Aug 31, 2009 9:31 pm

I had the power board out and found a few spots that have cold soldering. Rechecked the voltage to ballast and it is now 321v. I have checked for bad caps but don't see any. I'll look again and will try to find the reason why the wheel is not powered. So you are saying the wheel should be on even if the ballast is bad. I removed the color wheel and it does move freely .
Thanks for your response. :shock:

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: HD61LPW52 no lamp or color wheel power

Post by mitchkramez » Tue Sep 01, 2009 1:50 am

from everything i read, the color wheel should spin up even with the lamp removed (make sure you have something holding down the lamp door switch or nothing will happen :). 321v might be ok, another user reported 324 or so on their 50"...

You won't really be able to test the power coming out of the ballast, up firing up it'll be somewhere in the range of 15kv and destroy your multimeter!

Canondale
Contributor
Contributor
Posts: 11
Joined: Sat Jan 09, 2010 3:06 am

Re: HD61LPW52 no lamp or color wheel power

Post by Canondale » Sat Jan 09, 2010 8:06 pm

Not to hijack your thread, but i am curious about how you tested the voltage going to the ballast. Where did you meter?

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: HD61LPW52 no lamp or color wheel power

Post by puddinboo » Mon Jan 11, 2010 12:12 am

mitchkramez wrote:from everything i read, the color wheel should spin up even with the lamp removed (make sure you have something holding down the lamp door switch or nothing will happen :). 321v might be ok, another user reported 324 or so on their 50"...

You won't really be able to test the power coming out of the ballast, up firing up it'll be somewhere in the range of 15kv and destroy your multimeter!
yeah u can, I tried it ,the meter just glows bright, smells burnt and starts smoking, then u know u have lots of voltage and have to replace the meter ,but don`t try this at home lol :) (I wasn`t thinking that day).

Post Reply

Return to “RCA Discussion”