rca m50wh92syx1 question about bulbs not lasting

Moderator: Angel

Post Reply
puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Sat Oct 10, 2009 2:40 am

I have a question about my rca 50" dlp model M50WH92SYX1 which I purchased in 2007 ,1st bulb (osram) went in 9 months,2nd bulb (phillips)went in 8 months .I was wonddering if turnning the tv off and on about 6 times a day to save the life of the bulb is actually killing it quicker.should I just turn the tv on to watch it and leave it on all day is better than turnning it of and on a 1/2 dozzen times.or could something else be killing the bulb with in a year?

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Sat Oct 10, 2009 8:05 pm

hmm, that's a good question -- i have m50wh72s, which is nearly identical. i checked my bulb hours in the service menu the other day and i was at about 5000 hours (this is still the original bulb). for reference, this was used for a year (by the previous owner) it then stopped working, and they put it out in the garage, where it sat for another year, through a south dakota winter even. I've had the tv for a little over a couple of months now, and we turn it on and off, just as many times, i'd imagine. the bulb was even set at the brighter picture setting and not the longer bulb life setting.

a year of bulb life to me sounds like something else is wrong, or you've just had bad luck twice! might be worth 80 bucks to get it looked at...

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Sat Oct 10, 2009 11:50 pm

wonder how or if u can check the output of the ballast to the bulb. and wether the voltage going to the bulb is ac or dc ?

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Sun Oct 11, 2009 2:09 am

the power going to the ballast is DC i believe -- but i don't think you can measure the power to the bulb w/o some expensive equipment

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasti

Post by puddinboo » Sun Oct 11, 2009 2:24 pm

mitchkramez wrote:the power going to the ballast is DC i believe -- but i don't think you can measure the power to the bulb w/o some expensive equipment

thx for your replies. I thought u might be able to just use a multi meter to check ?

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Mon Oct 12, 2009 2:27 pm

i think the voltage going to the bulb will blow out an average multimeter when it's firing the bulb -- 15,000v. I won't pretend to be an electrical engineer, but knowing i was dealing with that kind of voltage was enough for me to bring mine in for a check up.

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasti

Post by puddinboo » Mon Oct 12, 2009 7:18 pm

mitchkramez wrote:i think the voltage going to the bulb will blow out an average multimeter when it's firing the bulb -- 15,000v. I won't pretend to be an electrical engineer, but knowing i was dealing with that kind of voltage was enough for me to bring mine in for a check up.
lol I just tried using my multimeter at 1000v dc and yeah ur right the meter glowed like a xmas tree oops live and learn.there goes $80.00 .so anyways I think the ballast is fine its working:).

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Tue Oct 13, 2009 3:15 pm

well igot my new bulb from DM and still having the same problem ,checked color wheel runs nice and smooth ,and then the tv powers down u can here a clicking noise each time it powers down and then back up just no pic it will only stay powered on for about 5-10 secs before it shuts down each time so I don`t know if its the power board or the ballast at this point ?
if someone could help me out that would be great thx.

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Tue Oct 13, 2009 7:12 pm

hello again, in your original post, you didn't mention what your tv was doing (the blinking lights) it's possible that you have some bad capacitors on your power supply, this is exactly what happened to my tv, on for 5 seconds, blink 5 times and off. Check over the power supply for any caps with puffy/bulging tops... especially the ones highlighted in red:

Image

I had those replaced at a local repair shop for $30 out the door, after that my tv has worked great!

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Tue Oct 13, 2009 7:15 pm

Let me know if you decide to throw the TV, I might be interested in the power supply (mine has a coil that hisses pretty loudly)

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Tue Oct 13, 2009 8:31 pm

I trippled check (observed caps )all look good I think its time to buy a new tv don`t want to keep spending money on this thing.
oh yeah it looks like somebody replaced the caps on the board too .this tv was a replacement tv from rca hmmmmmmmmmmmmmm?

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Tue Oct 13, 2009 8:45 pm

My power supply board is more square than the 1 in the pic.

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Wed Oct 14, 2009 3:54 pm

that's too bad, sometimes it's an easy fix, and sometimes it's not. i think based on the problems you've had, your logic is sound, time for a new tv -- and not an rca this time i hope :) i was just at sams club last night - they had a 50" panasonic plasma (display model) for $675... i wish i had more money :)

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Wed Oct 14, 2009 4:50 pm

I went out and got a 52" samsung lcd Tv with a 4 yr extended warranty .awsome pic on it too, I hope this 1 will last .but I do have parts from this rca TV if anyones interested ,but I don`t know whats good or bad though ,I think the color wheel is ok since it runs nice and smooth.as for the power board and ballest not quite sure(don`t see any burnt spots on either board, caps do look good not bulging or deformed in anyway).not quite sure how to tell if the light engine is good or not.the plexi glass is just like new to with no scratches.and possibly 2 bulbs could be good but I don`t know fur sure.anyone interested just pm me.

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Fri Oct 16, 2009 11:22 pm

ok my tv has been working flawless for about 4 hrs straight now after unplugging tv and shorting out capacitor 450v 47uf kxg on ballast board .when shorting out cap got a good spark from it .I`ll keep u guys updated if interested.seems weird to me ??

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Sun Oct 18, 2009 11:49 pm

well my tv has been running today for 8hrs straight without a glicth.could it be the cap on the ballast board is my question??

mitchkramez
Self-Proclaimed Guru
Self-Proclaimed Guru
Posts: 36
Joined: Tue Aug 18, 2009 9:45 pm

Re: rca m50wh92syx1 question about bulbs not lasti

Post by mitchkramez » Mon Oct 19, 2009 5:47 pm

if you had an arc, you're lucky it still works - better to use a lightbulb with some wires to slowly drain big caps like that -- anyways, it's possible that the arc re solidified a bad solder joint or something or perhaps you just had a loose/bad connection between the ps and the ballast, or the ballast and the bulb. who knows. hopefully it'll keep on trucking for you though!

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasti

Post by puddinboo » Mon Oct 19, 2009 6:14 pm

mitchkramez wrote:if you had an arc, you're lucky it still works - better to use a lightbulb with some wires to slowly drain big caps like that -- anyways, it's possible that the arc re solidified a bad solder joint or something or perhaps you just had a loose/bad connection between the ps and the ballast, or the ballast and the bulb. who knows. hopefully it'll keep on trucking for you though!
next time I`ll take ur advice and use a lightbulb. well thx for all ur help on this one and i`ll keep u updated on this unit
Now I have 2 big screen tv`s ,1 for the recroom and living room the kids will be happy now lol. :mrgreen:

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Thu Nov 05, 2009 2:01 am

just an update tv is still going strong with the old bulb :)

redman3170
Contributor
Contributor
Posts: 14
Joined: Wed Aug 12, 2009 12:39 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by redman3170 » Thu Nov 05, 2009 4:34 am

puddinboo, do you still have that color wheel off that RCA? If so I am interested in buying it from you!

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Thu Nov 05, 2009 12:59 pm

redman3170 wrote:puddinboo, do you still have that color wheel off that RCA? If so I am interested in buying it from you!
actualy I didn`t have to replace anything on this tv to fix it, I`m strarting to think it was a bad connection somewhere.
Red I`m sorry but I have no parts from this tv as they are all working and nothing was replaced, not even the bulb.

puddinboo
Contributor
Contributor
Posts: 17
Joined: Sat Oct 10, 2009 2:30 am

Re: rca m50wh92syx1 question about bulbs not lasting

Post by puddinboo » Sat Jan 02, 2010 4:37 am

just to update u guys my tv is still going strong must have been a bad connection.

Post Reply

Return to “RCA Discussion”