62HM196 - Opinions wanted.

Moderator: Angel

Post Reply
Huckafooter
Newbie
Newbie
Posts: 1
Joined: Tue Nov 01, 2011 10:59 pm

62HM196 - Opinions wanted.

Post by Huckafooter » Tue Nov 01, 2011 11:25 pm

First post here, nice forum! I've read a bunch of smart advice here so I thought I'd ask for some. So, I've had the Toshiba 62hm196 since they came out. First lamp lasted around 8000 hrs. We had the extended warranty on the set, and when it came time for a new bulb they sent a generic brand. It lasted around 3500 and blew. Not bad but not great. Anyway, in August I bought my third lamp, a Phoenix, which up until now I thought was the OEM brand plus it looks identical to the original lamp(which still works just very dim). A few weeks ago I started noticing some warm up flicker, which I have seen on every lamp before it expires - thats the best way I can describe it. Then it progressively got dimmer and dimmer, so I changed it to high mode ( I always use low). Today it blew. The company I ordered it from is taking care of it no problem. Great guys but I dont know if I can plug them on here or not. Ok......FINALLY my question: Since I bought what I thought was a quality lamp, should I be concerned about my ballast condition or did I possibly get a bad lamp? I have seen one online for $70 or so and have no issues with installing it. I dont want to be wasting good lamps if $70 will breathe new life into my set. I built my own projector years back and from what I can see its not a traditional ballast. Appears to be more of an electronic ballast. Do these wear out or just die? Sorry to overload and thanks for any info!

Post Reply

Return to “Toshiba DLP Discussion”